# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\$\d{1,3}(?:,\d{3})*(?:\s+(?:thousand|[mb]illion|[MB]illion)|[M])?"
test_str = ("The threat actors attacked its systems and encrypted the files and are apparently demanding $4.5 million for a decryptor and to prevent the release of stolen data.\n\n"
"The threat actors attacked its systems and encrypted the files and are apparently demanding $4.5 million for a decryptor and to prevent the release of stolen data.\n\n"
"$5 million\n\n"
"$5.3M \n\n"
"$5.6 million \n\n"
"$333,333\n\n"
"$2 million\n\n"
"$5.3M")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.