using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"19[78][^3-6]";
string input = @"1975 1976 1977 1978 1979 1980 1981 1982 1983 1984";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}