const regex = /19[78][^3-6]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('19[78][^3-6]', 'gm')
const str = `1975 1976 1977 1978 1979 1980 1981 1982 1983 1984`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}