package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)19[78][^3-6]`)
var str = `1975 1976 1977 1978 1979 1980 1981 1982 1983 1984`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}