$re = '/19[78][^3-6]/m';
$str = '1975 1976 1977 1978 1979 1980 1981 1982 1983 1984';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);