using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d\d\d-\d\d-\d\d\d\d";
string input = @"113-25=1902 182-82-0192 H23-_3-9982 1I1-O0-E38B";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}