package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d\d\d-\d\d-\d\d\d\d`)
var str = `113-25=1902 182-82-0192 H23-_3-9982 1I1-O0-E38B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}