re = /\d\d\d-\d\d-\d\d\d\d/m
str = '113-25=1902 182-82-0192 H23-_3-9982 1I1-O0-E38B'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end