// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d\d\d-\d\d-\d\d\d\d").unwrap();
let string = "113-25=1902 182-82-0192 H23-_3-9982 1I1-O0-E38B";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}