package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d*\.\d+[fF]|\d+\.\d*[fF]|\d+[fF])|(\d*\.\d+|\d+\.\d*)|(\d+[lL])|(\d+)`)
var str = `42L 12 x 3.4f 6l 3.3 0F L F .2F 0.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}