re = /(\d*\.\d+[fF]|\d+\.\d*[fF]|\d+[fF])|(\d*\.\d+|\d+\.\d*)|(\d+[lL])|(\d+)/m
str = '42L 12 x 3.4f 6l 3.3 0F L F .2F 0.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end