const regex = /(\d*\.\d+[fF]|\d+\.\d*[fF]|\d+[fF])|(\d*\.\d+|\d+\.\d*)|(\d+[lL])|(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*\\.\\d+[fF]|\\d+\\.\\d*[fF]|\\d+[fF])|(\\d*\\.\\d+|\\d+\\.\\d*)|(\\d+[lL])|(\\d+)', 'gm')
const str = `42L 12 x 3.4f 6l 3.3 0F L F .2F 0.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}