// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d*\.\d+[fF]|\d+\.\d*[fF]|\d+[fF])|(\d*\.\d+|\d+\.\d*)|(\d+[lL])|(\d+)").unwrap();
let string = "42L 12 x 3.4f 6l 3.3 0F L F .2F 0.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}