$re = '/(?:^| )(\d+(?:\.\d+)?[KMGT]B)/m';
$str = '6.6KB 1..3KB 12KB 5G 3.3MB KB .6.2TB 9MB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);