import re
regex = re.compile(r"(?:^| )(\d+(?:\.\d+)?[KMGT]B)", flags=re.MULTILINE)
test_str = "6.6KB 1..3KB 12KB 5G 3.3MB KB .6.2TB 9MB"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")