// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^| )(\d+(?:\.\d+)?[KMGT]B)").unwrap();
let string = "6.6KB 1..3KB 12KB 5G 3.3MB KB .6.2TB 9MB";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}