re = /(?:^| )(\d+(?:\.\d+)?[KMGT]B)/m
str = '6.6KB 1..3KB 12KB 5G 3.3MB KB .6.2TB 9MB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end