re = /(?m)^\/{2}(?!\/).*$/m
str = 'https://docs.asciidoctor.org/asciidoc/latest/comments/
ffds
//dfdfds
// kfjdkf lkdsfj lf //
/// not a comment
//// not a comment
//
// A single-line comment.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end