import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^|[A-Z\\p{P}])[A-Z]|(?<=\\p{P})\\p{P}|(?<=\\p{L})\\d|(((?<!^)(?<![\"'([\\{])[A-Z](?=[a-z]))|((?<=[a-z])[A-Z]))|(?<!^)(?=[[(\\{&])|(?<=[)\\]\\}!&\\}])";
final String string = "ThisIsAnExample.TitleHELLO-WORLD2019T.E.S.T.(Test)\"Test\"'Test'[Test]. OTPIsADevice";
final String subst = " $0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}