const regex = /(?<!^|[A-Z\p{P}])[A-Z]|(?<=\p{P})\p{P}|(?<=\p{L})\d|(((?<!^)(?<!["'([{])[A-Z](?=[a-z]))|((?<=[a-z])[A-Z]))|(?<!^)(?=[[({&])|(?<=[)\]}!&}])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^|[A-Z\\p{P}])[A-Z]|(?<=\\p{P})\\p{P}|(?<=\\p{L})\\d|(((?<!^)(?<!["\'([{])[A-Z](?=[a-z]))|((?<=[a-z])[A-Z]))|(?<!^)(?=[[({&])|(?<=[)\\]}!&}])', 'gm')
const str = `ThisIsAnExample.TitleHELLO-WORLD2019T.E.S.T.(Test)"Test"'Test'[Test]. OTPIsADevice`;
const subst = ` $0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);