use strict;
my $str = 'ThisIsAnExample.TitleHELLO-WORLD2019T.E.S.T.(Test)"Test"\'Test\'[Test]. OTPIsADevice';
my $regex = qr/(?<!^|[A-Z\p{P}])[A-Z]|(?<=\p{P})\p{P}|(?<=\p{L})\d|(((?<!^)(?<!["'([{])[A-Z](?=[a-z]))|((?<=[a-z])[A-Z]))|(?<!^)(?=[[({&])|(?<=[)\]}!&}])/mp;
my $subst = ' $0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";