$re = '/(?<!^|[A-Z\p{P}])[A-Z]|(?<=\p{P})\p{P}|(?<=\p{L})\d|(((?<!^)(?<!["\'([{])[A-Z](?=[a-z]))|((?<=[a-z])[A-Z]))|(?<!^)(?=[[({&])|(?<=[)\]}!&}])/m';
$str = 'ThisIsAnExample.TitleHELLO-WORLD2019T.E.S.T.(Test)"Test"\'Test\'[Test]. OTPIsADevice';
$subst = " $0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;