using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/domain\.com\/wp-content\/uploads\/.+-(?!(?:360x240|300x200|720x480))\d+x\d+\.jpg";
string input = @"https://domain.com/wp-content/uploads/name-file-300x200.jpg
https://domain.com/wp-content/uploads/name-file-360x240.jpg
https://domain.com/wp-content/uploads/name-file-720x480.jpg
https://domain.com/wp-content/uploads/name-file-1200x768.jpg
https://domain.com/wp-content/uploads/name-file-1400x900.jpg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}