$re = '/https:\/\/domain\.com\/wp-content\/uploads\/.+-(?!(?:360x240|300x200|720x480))\d+x\d+\.jpg/';
$str = 'https://domain.com/wp-content/uploads/name-file-300x200.jpg
https://domain.com/wp-content/uploads/name-file-360x240.jpg
https://domain.com/wp-content/uploads/name-file-720x480.jpg
https://domain.com/wp-content/uploads/name-file-1200x768.jpg
https://domain.com/wp-content/uploads/name-file-1400x900.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);