const regex = /https:\/\/domain\.com\/wp-content\/uploads\/.+-(?!(?:360x240|300x200|720x480))\d+x\d+\.jpg/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/domain\\.com\\\/wp-content\\\/uploads\\\/.+-(?!(?:360x240|300x200|720x480))\\d+x\\d+\\.jpg', 'g')
const str = `https://domain.com/wp-content/uploads/name-file-300x200.jpg
https://domain.com/wp-content/uploads/name-file-360x240.jpg
https://domain.com/wp-content/uploads/name-file-720x480.jpg
https://domain.com/wp-content/uploads/name-file-1200x768.jpg
https://domain.com/wp-content/uploads/name-file-1400x900.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}