re = /https:\/\/domain\.com\/wp-content\/uploads\/.+-(?!(?:360x240|300x200|720x480))\d+x\d+\.jpg/
str = 'https://domain.com/wp-content/uploads/name-file-300x200.jpg
https://domain.com/wp-content/uploads/name-file-360x240.jpg
https://domain.com/wp-content/uploads/name-file-720x480.jpg
https://domain.com/wp-content/uploads/name-file-1200x768.jpg
https://domain.com/wp-content/uploads/name-file-1400x900.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end