using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]{1,}\d{3,}\w?";
string input = @"Analysis shows this TOR was a dup of TOR 2222-0221.
Close to Y23456.
Recommend close this TOR to TOR YH321-2.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}