use strict;
my $str = 'Analysis shows this TOR was a dup of TOR 2222-0221.
Close to Y23456.
Recommend close this TOR to TOR YH321-2.';
my $regex = qr/[A-Z]{1,}\d{3,}\w?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}