package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{1,}\d{3,}\w?`)
var str = `Analysis shows this TOR was a dup of TOR 2222-0221.
Close to Y23456.
Recommend close this TOR to TOR YH321-2.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}