const regex = /[A-Z]{1,}\d{3,}\w?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]{1,}\\d{3,}\\w?', 'gm')
const str = `Analysis shows this TOR was a dup of TOR 2222-0221.
Close to Y23456.
Recommend close this TOR to TOR YH321-2.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}