# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Every )(month|\d months)(.*)/$1$2/gm;t' <<< "<select class=\"wcsatt-options-product-dropdown\" name=\"convert_to_sub_dropdown2495\">
<option selected=\"true\" value=\"1_month\">Every month for $11.25 (10% off)
</option><option value=\"2_month\">Every 2 months for $11.25 (10% off)
</option><option value=\"3_month\">Every 3 months for $11.25 (10% off)
</option><option value=\"4_month\">Every 4 months for $11.25 (10% off)
</option><option value=\"5_month\">Every 5 months for $11.25 (10% off)
</option><option value=\"6_month\">Every 6 months for $11.25 (10% off)
</option>
</select>"