import Foundation
let pattern = #"(Every )(month|\d months)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<select class="wcsatt-options-product-dropdown" name="convert_to_sub_dropdown2495">
<option selected="true" value="1_month">Every month for $11.25 (10% off)
</option><option value="2_month">Every 2 months for $11.25 (10% off)
</option><option value="3_month">Every 3 months for $11.25 (10% off)
</option><option value="4_month">Every 4 months for $11.25 (10% off)
</option><option value="5_month">Every 5 months for $11.25 (10% off)
</option><option value="6_month">Every 6 months for $11.25 (10% off)
</option>
</select>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)