# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Every )(month|\d months)(.*)"
test_str = ("<select class=\"wcsatt-options-product-dropdown\" name=\"convert_to_sub_dropdown2495\">\n"
" <option selected=\"true\" value=\"1_month\">Every month for $11.25 (10% off)\n"
" </option><option value=\"2_month\">Every 2 months for $11.25 (10% off)\n"
" </option><option value=\"3_month\">Every 3 months for $11.25 (10% off)\n"
" </option><option value=\"4_month\">Every 4 months for $11.25 (10% off)\n"
" </option><option value=\"5_month\">Every 5 months for $11.25 (10% off)\n"
" </option><option value=\"6_month\">Every 6 months for $11.25 (10% off)\n"
" </option>\n"
"</select>")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.