import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Every )(month|\\d months)(.*)";
final String string = "<select class=\"wcsatt-options-product-dropdown\" name=\"convert_to_sub_dropdown2495\">\n"
+ " <option selected=\"true\" value=\"1_month\">Every month for $11.25 (10% off)\n"
+ " </option><option value=\"2_month\">Every 2 months for $11.25 (10% off)\n"
+ " </option><option value=\"3_month\">Every 3 months for $11.25 (10% off)\n"
+ " </option><option value=\"4_month\">Every 4 months for $11.25 (10% off)\n"
+ " </option><option value=\"5_month\">Every 5 months for $11.25 (10% off)\n"
+ " </option><option value=\"6_month\">Every 6 months for $11.25 (10% off)\n"
+ " </option>\n"
+ "</select>";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}