# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^=]+(?==[^=]*$)//gm;t' <<< "I have candy='4' and ice cream = 'vanilla'
I have candy='4' and ice cream = 'vanilla' and house='big'"