import Foundation
let pattern = #"[^=]+(?==[^=]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I have candy='4' and ice cream = 'vanilla'
I have candy='4' and ice cream = 'vanilla' and house='big'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)