use strict;
my $str = 'I have candy=\'4\' and ice cream = \'vanilla\'
I have candy=\'4\' and ice cream = \'vanilla\' and house=\'big\'';
my $regex = qr/[^=]+(?==[^=]*$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";