$re = '/[^=]+(?==[^=]*$)/m';
$str = 'I have candy=\'4\' and ice cream = \'vanilla\'
I have candy=\'4\' and ice cream = \'vanilla\' and house=\'big\'';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;