#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((\b\w+(\s+\w+)*(\s+\w+)*\b))(\s+\1)+"
Local $sString = "RURAL ROUTE 2 RURAL ROUTE 2" & @CRLF & _
"route 2 route 2" & @CRLF & _
"route route route" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)