import re
regex = re.compile(r"((\b\w+(\s+\w+)*(\s+\w+)*\b))(\s+\1)+", flags=re.MULTILINE)
test_str = ("RURAL ROUTE 2 RURAL ROUTE 2\n"
"route 2 route 2\n"
"route route route\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)