$re = '/((\b\w+(\s+\w+)*(\s+\w+)*\b))(\s+\1)+/m';
$str = 'RURAL ROUTE 2 RURAL ROUTE 2
route 2 route 2
route route route
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;