import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\b\\w+(\\s+\\w+)*(\\s+\\w+)*\\b))(\\s+\\1)+";
final String string = "RURAL ROUTE 2 RURAL ROUTE 2\n"
+ "route 2 route 2\n"
+ "route route route\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}