const regex = /^([0-9A-F]{2}\s?)+(?=\sAA BB).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9A-F]{2}\\s?)+(?=\\sAA BB).*$', 'gm')
const str = `01 02 03 AA BB CC FF
01 02 03 01 02 03 01 02 AF AA BB CC FF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}