use strict;
my $str = '01 02 03 AA BB CC FF
01 02 03 01 02 03 01 02 AF AA BB CC FF';
my $regex = qr/^([0-9A-F]{2}\s?)+(?=\sAA BB).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}