$re = '/^([0-9A-F]{2}\s?)+(?=\sAA BB).*$/m';
$str = '01 02 03 AA BB CC FF
01 02 03 01 02 03 01 02 AF AA BB CC FF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);