re = /^([0-9A-F]{2}\s?)+(?=\sAA BB).*$/m
str = '01 02 03 AA BB CC FF
01 02 03 01 02 03 01 02 AF AA BB CC FF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end