package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)abc_def_[\d]+(\.json)`)
var str = `abc_def_comparison_001.json
abc_def_001.json
abc_def_12345.json`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}