re = /abc_def_[\d]+(\.json)/i
str = 'abc_def_comparison_001.json
abc_def_001.json
abc_def_12345.json'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end