$re = '/abc_def_[\d]+(\.json)/i';
$str = 'abc_def_comparison_001.json
abc_def_001.json
abc_def_12345.json';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);