// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)abc_def_[\d]+(\.json)").unwrap();
let string = "abc_def_comparison_001.json
abc_def_001.json
abc_def_12345.json";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}